CCNA (Cisco Certified Network Associate)

CCNA Ana Sayfa | CCNA Nedir?
ROUTER Nedir? | IOS | MODELLER | Uygulamalar
Yönlendirme Türleri | STATIK YÖNLENDIRME | RIP | IGRP | EIGRP| OSPF
Nedir? | Kurulum | Yapilandirma | Uygulamalar
Nedir? | Kurulum | Yapilandirma | Uygulamalar
Nedir? | Kurulum | Yapilandirma | Uygulamalar
Nedir? | Kurulum | Yapilandirma | Uygulamalar
Nedir? | Kurulum | Yapilandirma | Uygulamalar
Nedir? | Kurulum | Yapilandirma | Uygulamalar

HSRP (Hot Standby Router Protocol)


Cisco temelli LAN segmentindeki herhangi bir cihazın fail durumunda yada linkin fail durumunda atomatik olarak
görevlerin standby olarak tanımlanan cihaza aktarıldıgı yapıdır.

Uygulamada ortamda VIRTUAL ROUTER kullanılır. Virtual router ip adresi Active yapıda çalışacak cihazın
üzerinde

standby 1 ip 10.0.0.10
standby 1 priority 120

komutlarıyla tanımlanır. Standby cihazda Virtual tanımlaması daha düşük priority değeri ile tanımlanır.

standby 1 ip 10.0.0.10
standby 1 priority 110

 

HSRP_Switch_Merkez#show standby
FastEthernet0/0 - Group 1
State is Active
2 state changes, last state change 00:00:20
Virtual IP address is 10.0.0.10
Active virtual MAC address is 0000.0c07.ac01
Local virtual MAC address is 0000.0c07.ac01 (default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 0.328 secs
Preemption disabled
Active router is local
Standby router is 10.0.1.1, priority 110 (expires in 9.932 sec)
Priority 120 (configured 120)
IP redundancy name is "hsrp-Fa0/0-1" (default)

 

HSRP_Backup_Switch#show standby
FastEthernet0/0 - Group 1
State is Standby
19 state changes, last state change 00:00:27
Virtual IP address is 10.0.0.10
Active virtual MAC address is 0000.0c07.ac01
Local virtual MAC address is 0000.0c07.ac01 (default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 2.352 secs
Preemption disabled
Active router is 10.0.0.1, priority 120 (expires in 5.348 sec)
Standby router is local
Priority 110 (configured 110)
IP redundancy name is "hsrp-Fa0/0-1" (default)
HSRP_Backup_Switch#

HSRP yapılandırması IP yerine active router olarak seçilen cihazın MAC adresi verilerek de yapılabilir.

 

HSRP Routerları arasında Active Router herhangi bir sebep ile bu özelliğini kaybettikten sonra tekrar up olup düzgün çalışmaya
başlasa bile yeniden Active olamaz. Yeniden Active olabilmesi için mevcut Active Routerın (Daha önceki Standby Router) down olması gerekir. Bu durum default olarak enable olmayan Preemption işlemiyle düzeltilebilir.

Router(config-if)#standby 1 preempt

 

Bu bahsedilen tüm durumlar local tarafla ilgilidir.

HSRP konfigurasyonunun yapıldıgı interfaceler dışındaki interface lerin izlenebilmesi

standby 1 track type number 1
standby 1 track serial0/0 60

komutları ile sağlanır.

 

HSRP LOAD BALANCING: Fiziksel hatların her ikisininde kullanılabilmesi için cihazlarda 2 adet HSRP group açılır. Cihazın birinde ilk grup için priority yüksek, diğer cihazda ikinci grup için priority yüksek verilir. Grupların ip adresleri aynı subnette farklı ip ler olmalıdır. Local ağda ise istemcilerin ağ geçitleri Load Balanca işlemi için yarı yarıya dağıtılır.

Router1(config)#interface s0/0
Router1(config-if)#ip address 85.0.0.1 255.0.0.0
Router1(config-if)#standby 1 ip 85.0.0.90
Router1(config-if)#standby 1 priority 120
Router1(config-if)#standby 1 preempt
Router1(config-if)#standby 2 ip 85.0.0.100
Router1(config-if)#standby 2 priority 110
Router1(config-if)#standby 2 preempt
Router1(config-if)#end
Router1#

Router2(config)#interface s0/0
Router2(config-if)#ip address 85.0.0.2 255.0.0.0
Router2(config-if)#standby 1 ip 85.0.0.90
Router2(config-if)#standby 1 priority 110
Router2(config-if)#standby 1 preempt
Router2(config-if)#standby 2 ip 85.0.0.100
Router2(config-if)#standby 2 priority 120
Router2(config-if)#standby 2 preempt
Router2(config-if)#end
Router2#

aynı yapılandırma iç network içinde kullanılabilir.
Bu durumda %50 load balance yapılabilmesi için iç agdaki tüm aygıtlar gatewaylerini group 1 ve group 2 nin
ip adreslerine düzgün bir şekilde dagıtılmalıdır. Yani yarısı group 1 ip, diger yarısı group 2 ip
olarak gatewayleri tanımlanır.

 

HSRP arabirimlerinde ICMP paketlerinin alınabilmesi için

 

int fa0/0
standby redericts enable

int fa0/0
standby 1 timers 1 3

komutları ile timers ayarlanabilir.
Komut çift taraflı uygulanmalıdır.


 

| | | | ©2009 A. Alper Şahan